php 5.3.0からphp 5.2.10にダウングレード

2020年7月12日

先日php 5.3.0にアップグレードしましたが、wordpress 2.8.4で、一部プラグインが動作しないのと、

webアプリケーションが動作しなかったので、ダウングレードしました。

その時の手順です。

php5.3.0とモジュール関連をアンインストール

[root@centos ~]# yum -y remove php*
...
.....

remiからphp5.2.10と関連モジュールをダウンロード



64bitの場合


[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
[root@centos ~]#wget 
php 5.2.10と関連モジュールをインストール

[root@centos ~]#rpm -ivh php-cli-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-common-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-gd-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-ldap-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-mbstring-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-mcrypt-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-mysql-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-pdo-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-snmp-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-xml-5.2.10-1.el5.remi.i386.rpm
[root@centos ~]#rpm -ivh php-xmlrpc-5.2.10-1.el5.remi.i386.rpm

これで、正常動作するようになりました。

CentOS5.3php

Posted by kencom